brew install i386-elf-gcc and error:contains conflicting version recursive dependencies

brew install i386-elf-gcc

==> Installing i386-elf-gcc from altkatz/gcc_cross_compilers
Error: altkatz/gcc_cross_compilers/i386-elf-gcc contains conflicting version recursive dependencies:
gmp, gmp@4, mpfr, mpfr@2, libmpc, libmpc@0.8

View these with brew deps --tree altkatz/gcc_cross_compilers/i386-elf-gcc.

And the debs tree looks like:

altkatz/gcc_cross_compilers/i386-elf-gcc
├── gmp
├── libmpc
│   ├── gmp
│   └── mpfr
│       └── gmp
├── mpfr
│   └── gmp
└── i386-elf-binutils

After I installed the gmp@4,mpfr@2,libmpc@0.8,gcc49 ,the error doesn’t change .

brew install i386-elf-gcc and error:contains conflicting version recursive dependencies